[Haskell-cafe] cabal errors

Kristofer Buffington kristoferbuffington at gmail.com
Thu Feb 28 07:10:03 EST 2008


I installed ghc 6.8 from source and I've been installing packages from
hackage. I'm not sure when the problem started, but I've been getting this
error trying to install any cabal package.. accept apparently, Cabal itself.

    Warning: Deprecated use of `defaultUserHooks'
             (imported from Distribution.Simple):
             Use simpleUserHooks or autoconfUserHooks
Setup: /usr/local/lib/Cabal-1.3.6/ghc-
unknown symbol `directoryzm1zi0zi0zi0_SystemziDirectory_a9_closure'
Setup: exception :: GhcException

Any ideas?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20080228/bbfbfe84/attachment.htm

More information about the Haskell-Cafe mailing list