[Haskell-cafe] Haskell wiki is searched by google.

Richard Kelsall r.kelsall at millstream.com
Thu Feb 14 09:27:40 EST 2008

Mads Lindstrøm wrote:
> Richard Kelsall wrote:
>> Daniil Elovkov wrote:
>>> Hello
>>> I remember there was a problem with haskell wiki pages not being indexed 
>>> and searched.
>>> Now it seems to work perfectly. Actually typing 'monomorphism 
>>> restriction' in google I see the appropriate wiki page as the first result.
>>> I must have missed the moment when it was fixed. Just sharing my 
>>> observations. Thanks.
>> Hello Daniil, I think I may have started that discussion here :
>> http://www.haskell.org/pipermail/haskell-cafe/2007-November/035127.html
>> but sadly a search for mdo in the Search box at the top of this page
>> http://haskell.org/haskellwiki/Haskell
>> still gives no results. I suspect something needs adjusting in the
>> configuration of MediaWiki for the haskellwiki.
> Not MediaWiki, but the underlying database. If HaskellWiki uses MySql
> ft_min_word_len needs to be set to something smaller than four. See
> http://dev.mysql.com/doc/refman/5.0/en/fulltext-fine-tuning.html . After
> doing this the indexes needs to be rebuild.

Testing using this page


by searching for words which I can see are on the page I get

   Not found      Found
   ---------      -----
   mdo            Phooey
   map            wire
   way            play
   let            persistence

So three character words don't get indexed but four character words do.

I mentioned in the previous thread that some longer words weren't
getting indexed. It looks like this has been fixed. All the long words
I just tried worked properly. And, better than Google, the words get
indexed as soon as they are changed. I tried searches for words added
this afternoon and they returned up-to-date results. Excellent! Whoever
it was thank you for fixing the search.


More information about the Haskell-Cafe mailing list