[Haskell-cafe] Can't cabal install readline

Martijn van Steenbergen martijn at van.steenbergen.nl
Sat Dec 6 16:32:16 EST 2008

Judah Jacobson wrote:
> The following instructions should re-enable Ctrl-R:
> http://mult.ifario.us/p/editrc-tidbit-for-ghci

Yes, that worked perfectly, thanks!

> The above happens because GHC is using the OS X default installation
> of libreadline.a which is actually a link to libedit that doesn't
> implement the full readline API.
> If you already have the MacPorts readline, you just need to tell cabal
> where it is, with (for example)
> cabal install readline --extra-include-dirs=/opt/local/include
> --extra-lib-dirs=/opt/local/lib

This didn't immediately fix the problem. But I found out readline was 
installed but deactivated, which explained why there was nothing 
readline-related in /opt/local/lib. Reactivating fixed it; I didn't even 
need to give cabal install any extra hints.

Thanks for the help. :-)


More information about the Haskell-Cafe mailing list