[Haskell-cafe] "build depends:" in a .cabal file

Brandon S. Allbery KF8NH allbery at ece.cmu.edu
Mon Aug 18 17:41:05 EDT 2008

On 2008 Aug 18, at 17:30, Jason Dagit wrote:
> In my experience, with recent GHC there are only 3 packages needed to
> install cabal-install and it's pretty painless.  You need zlib, HTTP
> and something else that I can't recall off the top of my head (but it
> tells you).  Each of these packages can be had from hackage and they
> are very standard cabal installations.  Sometimes you also need to
> upgrade cabal; I don't think this was an issue with ghc 6.8.2 and
> newer though.

When I installed cabal-install under 6.8.2 I also had to get a Cabal  
1.4 prerelease from darcs, IIRC.

cabal-install would be helped a lot by either (a) being folded into  
Cabal, and in particular the Cabal that comes with GHC; or, failing  
that, (b) being available as a prebuilt bootstrap package.

brandon s. allbery [solaris,freebsd,perl,pugs,haskell] allbery at kf8nh.com
system administrator [openafs,heimdal,too many hats] allbery at ece.cmu.edu
electrical and computer engineering, carnegie mellon university    KF8NH

More information about the Haskell-Cafe mailing list