[Haskell-cafe] Building fastcgi from hackage on windows.

Iain Barnett iainspeed at gmail.com
Thu Aug 7 19:54:28 EDT 2008

On 7 Aug 2008, at 8:58 pm, Edward Ing wrote:

> I am using the cabal system to build the hackage version of fastcgi.
> I get the below messages with the "runghc Setup.lhs build" command.
> Network\FastCGI.hsc:59:21:  fcgiapp.h: No such file or directory
> Network\FastCGI.hsc: In function `main':
> Network\FastCGI.hsc:200:0:
>      error: `FCGX_Request' undeclared (first use in this function)
> It looks like I need the fastcgi sources. Where does this source come
> from? I didn't get any dependency messages when I did the setup
> config.
> Edward Ing
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

I had a similar problem about a month ago, but I can't remember  
*exactly* what I did to fix it. I think I made sure the following  
were installed (I'm pretty sure I ran cabal installs for all of them  
regardless of what ghc-pkg told me, and it worked)


 From my cabal build-log:

package: fastcgi-3001.0.2
os: osx
arch: i386
compiler: ghc-6.6
client: cabal-install-0.5.1
flags: -small_base
dependencies: base-2.0 cgi-3001.1.6.0
install-outcome: InstallOk
docs-outcome: NotTried
tests-outcome: NotTried

Sorry to be so vague, but I mainly remember swearing a lot at the  
screen until it worked.


More information about the Haskell-Cafe mailing list