[Haskell-cafe] Re: ANN: Haddock version 2.2.1

Christian Maeder Christian.Maeder at dfki.de
Mon Aug 4 14:47:12 EDT 2008


It seems that the dependencies for ghc-paths could be improved.

Thanks Christian

Gwern Branwen wrote:
> On 2008.08.04 19:32:13 +0200, Christian Maeder <Christian.Maeder at dfki.de> scribbled 3.0K characters:
>> http://hackage.haskell.org/cgi-bin/hackage-scripts/package/haddock-2.2.1
>> depends on ghc-paths
>> http://hackage.haskell.org/cgi-bin/hackage-scripts/package/ghc-paths-
>> ghc-paths failed for me with:
>> Setup.hs:7:7:
>>     Could not find module `Distribution.Simple.PackageIndex':
>> I've ghc-6.8.3 and Cabal-
>> Can haddock-2.2.1 replace may old haddock-0.8 (or haddock-0.9)?

I'm still struggling with this point. haddock-0.8 accepted the same file 
multiple times and several Main modules.

>> Cheers Christian
> ghc-paths is very picky about its cabal version. Apparently Cabal 1.4.x works; you can get it from darcs at <http://darcs.haskell.org/cabal-branches/cabal-1.4> (dunno about any packages).
> --
> gwern
> monarchist emc Taiwan SIGDASYS ation HRT SURSAT GNU OPS Ingram

More information about the Haskell-Cafe mailing list