[Haskell-cafe] Re: HaXml and the XHTML 1.0 Strict DTD

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Wed Apr 30 07:01:21 EDT 2008

On Wed, 2008-04-30 at 11:32 +0100, Malcolm Wallace wrote:
> Peter Gammie <peteg42 at gmail.com> wrote:
> > The most-recent darcs version relies on a newer ByteString than I  
> > have, so it is not easy for me to test it.
> I believe there was a patch to fix this.  Apparently only one version of
> the bytestring package ( ever exported the 'join' function, and
> a different version with the same number (but not exporting 'join') was
> uploaded to Hackage!  'Join' has since been replaced by 'intercalate',
> which is available in all versions 0.9.x.

Just goes to show that we need a tool to compare and check package APIs
so that packages that want to follow a versioning policy can check that
they really are. Doing these things manually is prone to mistakes like
this one (and another that I'm aware of in the same package).


More information about the Haskell-Cafe mailing list