[Haskell-cafe] Hackage being too strict?

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Wed Apr 23 19:11:45 EDT 2008

Just to keep haskell-cafe updated on this issue...

On Tue, 2008-04-15 at 22:15 -0500, John Goerzen wrote:
> When I went to make my upload of MissingH 1.0.1, Hackage rejected it,
> saying:
> Instead of 'ghc-options: -XPatternSignatures' use 'extensions: PatternSignatures'

Now fixed!

(Well, at least it's fixed in Cabal. Hopefully the hackage scripts will
get rebuilt against the latest Cabal some time in the next few days.)

For extensions that are present in ghc-6.8 but not 6.6 hackage will not
warn about using ghc-options: -XTheExtensionName.

> Now, my .cabal file has this:
>  -- Hack because ghc-6.6 and the Cabal the comes with ghc-6.8.1
>  -- does not understand the PatternSignatures extension.
>  -- The Cabal that comes with ghc-6.8.2 does understand it, so
>  -- this hack can be dropped if we require Cabal-Version: >=1.2.3
>  If impl(ghc >= 6.8)
>    GHC-Options: -XPatternSignatures

So this will work fine.

If one did add:
Cabal-Version: >=1.2

then hackage would again complain about ghc-options: -XPatternSignatures
but in this case it's legitimate again to complain because we can use
extensions: PatternSignatures since that does work with cabal >= 1.2.

In addition, as I previously mentioned, this whole problem of old
versions not knowing about new extensions will go away from Cabal-1.4


More information about the Haskell-Cafe mailing list