[Haskell-cafe] library version problem

Ketil Malde ketil at malde.org
Fri Apr 11 06:54:08 EDT 2008

Ketil Malde <ketil at malde.org> writes:

> Either rename your modified version to 2.4 (or similar), specify the
> exact version in your *application's* cabal file, 

..or you could compile your application specifying the package
explicitly, using "-package unix-" (and all the other packages,
normally supplied by Cabal or ghc --make).

> or use "ghc-pkg hide" to hide version from view.

If I haven't seen further, it is by standing in the footprints of giants

More information about the Haskell-Cafe mailing list