[Haskell-cafe] problems building hpodder

John Goerzen jgoerzen at complete.org
Mon Apr 7 21:20:24 EDT 2008

On Monday 07 April 2008 5:57:39 pm gwern0 at gmail.com wrote:

> So almost certainly the issue is that HaXml has updated and changed things
> around in a way that broke Hpodder; not surprising, since HaXml-1.19.2 is
> as recent as 14 January 2008, and Goerzen may simply not have updated and
> discovered the error before he released Hpodder in February.

I won't be updating it anytime soon, in fact.  1.19.2 is a development 
version, according to the author, so I will stick with 1.13.3 -- the stable, 
released version.  Unfortunately, Hackage has no way to indicate stable vs. 
alpha, I guess.  (That would make life easier here.)  I suppose I ought to 
also post something on the hpodder wiki and update the Cabal build-deps so 
it gets the right HaXml version.

> If the problem is too-recent HaXml, there's an obvious work around. You
> could install HaXml-1.13.3
> <http://hackage.haskell.org/cgi-bin/hackage-scripts/package/HaXml-1.13.3>
> and edit the hpodder.cabal file to replace the 'HaXml>=' bit with
> 'HaXml==1.13.3'. That works for me.
> --
> gwern
> Etacs FOSS NTIS SUPIR mindwar NATOA SARA niche DNR 3B2

More information about the Haskell-Cafe mailing list