[Haskell-cafe] Re: trying to install ghc-6.8.2 both binaries and sources

Christian Maeder Christian.Maeder at dfki.de
Fri Apr 4 03:56:22 EDT 2008

michael at schmong.org wrote:
> I am operating under the assumption that Idid have a broken gcc.

Your gcc is not broken, but a bit old (for a new ghc-6.8.2)

> Which we'll further canonicalise into: i386-unknown-linux
> checking for path to top of build tree... pwd: timer_create: Operation
> not supported
> configure: error: cannot determine current directory

This timer_create error is due to an old glibc. If it comes from the
installation of
than you have to install an older version (i.e. ghc-6.4.2)


If you (or what or however installs your software) installed my version
(or your version was created differently) than try the above ghc-6.8.2
version first.

Usually ghc is installed under /usr/local/ so the binary script is
/usr/local/bin/ghc. If no idea why your ghc is /usr/bin/ghc. It's either
a link or it was installed using --prefix=/usr. (debian users may know)

Cheers Christian

More information about the Haskell-Cafe mailing list