[Haskell-cafe] wxhaskell package for ubuntu feisty, amd64

shelarcy shelarcy at gmail.com
Thu Sep 20 04:19:43 EDT 2007

Hi Iván,

On Fri, 14 Sep 2007 20:16:29 +0900, Iván Pérez Domínguez <iperez at babel.ls.fi.upm.es> wrote:
> Already had. Didn't work.
> This is what it reported:
> wxc/src/ewxw/eljcursor.cpp: In function ‘void* Cursor_CreateLoad(const
> wxString*, long int, int, int)’:
> wxc/src/ewxw/eljcursor.cpp:18: error: no matching function for call to
> ‘wxCursor::wxCursor(const wxString&, long int&, int&, int&)’
> /usr/include/wx-2.6/wx/gtk/cursor.h:42: note: candidates are:
> wxCursor::wxCursor(const char*, int, int, int, int, const char*,
> wxColour*, wxColour*)
> /usr/include/wx-2.6/wx/gtk/cursor.h:38: note: wxCursor::wxCursor(const
> wxImage&)
> /usr/include/wx-2.6/wx/gtk/cursor.h:36: note: wxCursor::wxCursor(const
> wxCursor&)
> /usr/include/wx-2.6/wx/gtk/cursor.h:35: note: wxCursor::wxCursor(int)
> /usr/include/wx-2.6/wx/gtk/cursor.h:34: note: wxCursor::wxCursor()
> make: *** [out/wxc/ewxw/eljcursor.o] Erro 1
> I googled it and couldn't find the solution.

Mad fixed this problem.

So you must get newer darcs version, and build wxhaskell again.

Best Regards,

shelarcy <shelarcy    hotmail.co.jp>

More information about the Haskell-Cafe mailing list