[Haskell-cafe] Re: [Haskell] Re: Trying to install binary-0.4

Ian Lynagh igloo at earth.li
Wed Oct 17 09:39:49 EDT 2007

On Wed, Oct 17, 2007 at 12:54:12PM +0100, Simon Marlow wrote:
> I've written down the proposed policy for versioning here:
>   http://haskell.org/haskellwiki/Package_versioning_policy

This says:
    If [...] instances were added or removed, then the new A.B must be
    greater than the previous A.B.
This presumably includes changing module imports, or depending on a
newer version of a package, which results in the visible instances
changing? I think this should be spelt out in the policy.

The example:
    build-depends: mypkg == 2.1.1
should be:
    build-depends: mypkg >= 2.1.1, mypkg < 2.1.2
with the current dependency syntax/semantics.


More information about the Haskell-Cafe mailing list