[Haskell-cafe] Re: cabal-install

Ben Franksen ben.franksen at online.de
Wed Nov 28 14:46:36 EST 2007

Don Stewart wrote:
> ben.franksen:
>> cabal: dist/Conftest.c: openFile: does not exist (No such file or
>> directory)
> This one is due to having an out of date cabal. Upgrade to darcs cabal,
> then rebuild cabal-install, and things should go fine.

Ok. So the package is broken in that it doesn't work with the advertised
version of Cabal as stated on hackage:
See the line 

base (>=2.0&&<2.2), Cabal (>=1.2), filepath (>=1.0), HTTP
(>=3000.0&&<3001.1), network, zlib (>=0.3)

Anyway, I'll follow your advice & install latest cabal from darcs repo. (*
looks for repo URL in Cabal home page; under "Download", nothing, hmmm; ah
it's under "Source Code", right. Wait for darcs to finish getting...here we
go *)

ben at sarun: .../software/haskell > darcs get --partial
Copying patch 115 of 115... done!
Applying patch 114 of 114... done.
Finished getting.
ben at sarun: .../software/haskell > cd cabal
ben at sarun: .../haskell/cabal > runhaskell Setup.lhs configure

Distribution/Simple/NHC.hs:77:1: lexical error at character 'i'


Ben (feels like a real beta-tester now ;-)

More information about the Haskell-Cafe mailing list