[Haskell-cafe] cabal-install

Ben Franksen ben.franksen at online.de
Tue Nov 27 19:21:28 EST 2007

Just thought I install the latest version (0.4.0) from hackage and test it.
Build and install went fine, but then it gets strange:

ben at sarun: .../haskell/cabal-install-0.4.0 > sudo runhaskell Setup.lhs
Installing: /usr/local/bin
ben at sarun: .../haskell/cabal-install-0.4.0 > rehash
ben at sarun: .../haskell/cabal-install-0.4.0 > cabal --help
Usage: cabal [GLOBAL FLAGS]
  or:  cabal COMMAND [FLAGS]


  fetch      Downloads packages for later installation or study.
  install    Installs a list of packages.
  update     Updates list of known packages
  clean      Removes downloaded files
  list       List available packages on the server.
  info       Emit some info
ben at sarun: .../haskell/cabal-install-0.4.0 > cd ..
ben at sarun: .../software/haskell > cabal info
Config file /home/ben/.cabal/config not found.
Writing default configuration to /home/ben/.cabal/config.
cabal: dist/Conftest.c: openFile: does not exist (No such file or directory)

When later I tried the 'install' command, it reminds me to 'cabal update'
first, which I do (no response, so probably worked), however next 'cabal
install' gives the same funny answer about a missing dist/Conftest.c.



More information about the Haskell-Cafe mailing list