[Haskell-cafe] IDE?

Donnchadh Ó Donnabháin donnchadh at gmail.com
Sun Jun 17 14:35:07 EDT 2007

On 6/17/07, Hans van Thiel <hthiel.char at zonnet.nl> wrote:
> On Sun, 2007-06-17 at 02:00 +0100, Donnchadh Ó Donnabháin wrote:
> What operating system do you use? I've tried it several times on Fedora
> Core 6 but it doesn't work, either with the FC Eclipse or the official
> Eclipse version. The Haskell plug-in  installs fine, but the editor
> crashes, not always the same way.
> The problem seems to be the different Java versions, and Java Virtual
> Machines, which are in use on different systems. The Fedora Eclipse also
> has problems with some other plug-ins which are not supported (yet).

  I use both windows and fedora. I don't use the fedora-provided
eclipse. Instead I have installed Sun's JVM (1.6.0 update 1) and
downloaded eclipse from eclipse.org .

I use eclipse on fedora every day with a multitude of plugins and it
seems to be very stable when run on the Sun JVM.

In the past I have had problems running eclipse with GCJ.

I haven't really had a chance to use eclipsefp in anger yet, but
syntax highlighting, error highlighting and compiling work. Runnging
in ghci didn't seem to work for me but I must look into that. No
crashes or exceptions yet.


More information about the Haskell-Cafe mailing list