[Haskell-cafe] no end to the build errors! (wxhaskell, afrp)

Yang hehx0sk02 at sneakemail.com
Sun Jan 7 20:54:49 EST 2007

thanks for the timely response.

using this wxhaskell and the (just-in-time re-released) yampa (it
built/installed fine, unlike the old afrp release i tried earlier), i
tried again to build wxfruit:

$ ghc --make WXFruit.hs

    Could not find module `Graphics.UI.WX':

looking into this, it appears that either wxhaskell has recently
(judging from the docs on the official wxhaskell site) undergone a big
reorg, or i'm still missing some wxhaskell libs. does this mean that i
won't be able to get wxfruit working (without hacking it to update its
usage of wxhaskell)?


On 1/7/07, Brandon S. Allbery KF8NH allbery-at-ece.cmu.edu
|haskell-cafe| <...> wrote:
> On Jan 7, 2007, at 17:56 , Yang wrote:
> > == wxhaskell-0.9.4 ==
> Ditch it; it hates ghc 6.6.  darcs get http://darcs.haskell.org/
> wxhaskell
> I can't help with the others.
> --
> brandon s. allbery    [linux,solaris,freebsd,perl]     allbery at kf8nh.com
> system administrator [openafs,heimdal,too many hats] allbery at ece.cmu.edu
> electrical and computer engineering, carnegie mellon university    KF8NH

More information about the Haskell-Cafe mailing list