[Haskell-cafe] Error building Edison

Gregory Wright gwright at comcast.net
Tue Oct 17 13:46:09 EDT 2006

On Oct 17, 2006, at 1:07 PM, Robert Dockins wrote:

> On Oct 17, 2006, at 12:55 PM, Gregory Wright wrote:
>> Hi Rob,
>> I've built Edison using ghc-6.6.  (I'm testing the macports,
>> formerly darwinports, packages for the new 6.6 release.)
>> The build goes fine, but the ./Setup register fails claiming that  
>> the directory
>> /opt/local/lib/EdisonAPI-1.2/ghc-6.6/include does not exist.  I  
>> can make the
>> directory by hand, and the registration works.  I have an ugly  
>> workaround,
>> but I wanted to check with you that this is really a cabal bug.   
>> Installation
>> using ghc-6.4.2 on OS X/ppc worked just fine for me.
>> Best Wishes,
>> Greg
> I'm not doing anything unusual with the cabal scripts (that I'm  
> aware of!), so I expect this is a cabal or GHC bug.
> BTW, could you run the test suite if you get a moment?  Every data  
> point helps.

Hi Rob,

OK, it looks like cabal has gone slightly broken again. :-(

Here's the test data:

	OS X 10.4.8/ppc
	PowerBook G4, 1.5 GHz, 1 GB ram
	ghc-6.6, cabal 1.1.6 as distributed with ghc-6.6, built using macports
test output:

Welcome to Darwin!
crossroads-able> cd ~/Desktop/edison-
crossroads-able> ./dist/build/testSuite/testSuite
Cases: 1728  Tried: 1728  Errors: 0  Failures: 0

Everything looks good but for the package registration.

I should add that I find the Edison package wonderfully easy
to work with.  It has really helped me out while writing simulation
of the custom communication system for a customer.  Many thanks
to you, Rob, and Chris Okasaki for this fine software!

Best Wishes,

> Rob Dockins
> Speak softly and drive a Sherman tank.
> Laugh hard; it's a long way to the bank.
>           -- TMBG
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list