[Haskell-cafe] Fwd: [GHC] #939: Possible bug building wxhaskell

shelarcy shelarcy at gmail.com
Sat Oct 14 07:32:07 EDT 2006

Hi Jason,

Jun Mukai aka. jmuk already tried and successed
to build wxhaskell on GHC 6.6.

Here is his install log.

And I made patch for ghc 6.6 from it.
Attached solves a few problem ... but you must be
careful to your permission.

This patch solve package's interface problem with
separated build and install process support. And
"make" ("make all") depend on installing wxcore.
So you have to use "sudo" other than Windows.

I don't know what is the best approach. But advantage
is We can make binary (easy install) package for Windows
and Mac OS X user.

You can build binary package following command.

make before-dist
make bindist

Note that attached fix only GHC 6.6 problem, doesn't
fix other - no GHC 6.6 reason - problems.

If you will failure to build from other problems, you
must see this page first.


Best Regards,

On Sat, 14 Oct 2006 09:29:45 +0900, Jason Dagit <dagit at codersbase.com> wrote:
> I reported the following bug and received the response below.  Any
> wxhaskell hackers up to the challenge?  I'd really love to see the
> makefiles go away and see wxhaskell just use cabal but I don't know if
> that's possible given the wxhaskell build requirements.
> Any help is much appreciated.
> Thanks
> Jason
> ---------- Forwarded message ----------
> From: GHC <trac at galois.com>
> Date: Oct 13, 2006 5:21 PM
> Subject: Re: [GHC] #939: Possible bug building wxhaskell
> To: dagit at codersbase.com
> #939: Possible bug building wxhaskell
> -------------------------------------+--------------------------------------
>     Reporter:  dagit at codersbase.com  |        Owner:
>         Type:  bug                   |       Status:  closed
>     Priority:  normal                |    Milestone:
>    Component:  Compiler              |      Version:  6.6
>     Severity:  normal                |   Resolution:  invalid
>     Keywords:                        |   Difficulty:  Unknown
> Architecture:  x86                   |           Os:  Unknown
> -------------------------------------+--------------------------------------
> Changes (by duncan):
>   * resolution:  => invalid
>   * status:  new => closed
> Comment:
>  It's not a GHC bug. It's a problem with the way wxHaskell is built.
>  Admitidedly this is due to a slight change in the way GHC manages packages
>  but it's not a bug as such, wxHaskell just needs fixing.
>  What needs to happen is that the packages must be registered locally
>  before they get used in other packages. Also, instead of importing the
>  modules from the other package directly from the directory with -i foo/,
>  it must be via -package foo.
>  So you'll need to get in contact with someone who knows enough about
>  wxHaskell's build system to fix it. Try asking on the ghc-users or
>  haskell-cafe mailing lists.
> ------------------------
> The bug report:
> I appologize if this isn't a GHC bug but since it started happening after
>  a GHC upgrade I suspect it's a GHC bug.
>  After upgrading to ghc6.6 on windows (using the release binary) I tried to
>  install the current wxhaskell release found here:
>  http://wxhaskell.sourceforge.net/download.html
>  (version wxhaskell-src-0.9.4-1.zip)
>  I have used wxhaskell on this machine before with older version of ghc
>  (including ghc6.5, specifically visual haskell) so my environment for
>  building the wxhaskell source was already setup.  When I first got the
>  error below I thought maybe my version of wxhaskell was messed up so I
>  redownloaded the above zip file and unzipped a fresh copy.
>  I unziped the source then I typed:
>  configure && make
>  Things went along fairly smoothly for a while then suddenly I got this
>  error message:
>  ghc -c wx/src/Graphics/UI/WX/Types.hs -o
>  out/wx/imports/Graphics/UI/WX/Types.o -iout/wx/imports -odir
>  out/wx/imports -hidir out/wx/imports  -fvia-C -package-name wx
>  -iout/wx/imports
>  wx/src/Graphics/UI/WX/Types.hs:94:0:
>     Bad interface file: out/wx/imports/Graphics/UI/WXCore/Types.hi
>         Something is amiss; requested module  wx:Graphics.UI.WXCore.Types
>  differs from name found in the interface file
>  wxcore:Graphics.UI.WXCore.Types
>  make: *** [out/wx/imports/Graphics/UI/WX/Types.o] Error 1

shelarcy <shelarcy    capella.freemail.ne.jp>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: fix_building_ghc-6.6.diff
Type: application/octet-stream
Size: 2728 bytes
Desc: not available
Url : http://www.haskell.org/pipermail/haskell-cafe/attachments/20061014/03ccbfe2/fix_building_ghc-6.6.obj

More information about the Haskell-Cafe mailing list