[Haskell-cafe] hs-plugins/ haskelldb/ ELF zlib incompatibility.

Björn Bringert bringert at cs.chalmers.se
Mon Mar 20 07:36:29 EST 2006

Marc Weber wrote:
> I get this error:
> calhost db=store uid=marc pwd=" DB/Direct: Daan Leijen (c) 1999, HWT
> (c) 2003-2004, Bjorn Bringert (c) 2005
> Connecting to database... DBDirect: user error (loadShared: couldn't
> load `/usr/lib/libz.so' because /usr/lib/libz.so: invalid ELF header
> Any idea how to fix it ? (What to watch for?)
> latest cvs ghc, latest darcs hs-plugins (dons told me to ask the 
> haskelldb how they managed to run it..) I've tried compiling with -lz
> option. Same result. I'm also posting here because I don't know how
> frequently the haskelldb mailinglist is read yet.. It doesn't seem to
> be used by that much people yet.

I don't think that this is HaskellDB specific, so I'll post my reply
here as well (this is the same as my reply to you post to haskelldb-users):

I once ran into a similar problem in ghci when I had an unneccessary
"-lc" in the package configuration, and my libc.so was a linker script.
I'm guessing that this is the same problem, since DBDirect uses
hs-plugins to load a module which requires libz. Maybe you could try 
loading the HSQL MySQL module into ghci and see if you get the same 
problem. If you do, you could try to remove libz from the 
extra-libraries list in the package configuration for hsql-mysql.


More information about the Haskell-Cafe mailing list