[Haskell-cafe] Haddock Problems

Daniel Fischer daniel.is.fischer at web.de
Thu Mar 9 09:42:40 EST 2006

Now all's well.
I rebuilt the complete ghc together with haddock-0.7 (I'm not _that_ mad, 
when I got my new hard-disk, I forgot to install an OpenGL package, so my ghc 
didn't build that and I wanted to rebuild ghc anyway), but surely there must 
be an easier way to upgrade haddock.
Originally, I just did
make install
in /usr/local/lib/haddock-0.7
and when I tried
make install-docs
in /usr/local/lib/ghc-6.2.2, I got the error below, so upgrading haddock and 
the ghc-docs isn't so easy.
What is the proper way to do it?


Am Dienstag, 7. März 2006 20:55 schrieb Daniel Fischer:
> Hi all,
> I've just installed haddock-0.7, nice, but...
> > haddock -o h7doc -h -D h7doc/fusi.haddock --use-package=base
> > Verwaltung.hs
> Teams.hs Stats.hs Match.hs Main.hs Liga.hs Item.hs Helpers.hs Datum.hs
> Warning: Helpers: could not find link destinations for:
>     GHC.Base.Int GHC.Base.String GHC.Show.Show Data.Maybe.Maybe GHC.Base.Eq
> GHC.Base.Bool
> and so on.
> Same problem, if I use "-i/usr/.../base.haddock" instead of
> --use-package=base. This doesn't happen with haddock-0.6, all are properly
> linked to Prelude.html then.
> Now what can I do about that?
> BTW, in the ghc-docs (created with haddock-0.6), in most html-pages, Int &c
> are linked to GHC.Base, GHC.Num... which don't exist, how would I manage to
> have those linked to Prelude.html?
> And when I tried to re-make install-docs (for ghc-6.2.2, not to put the
> 6.4.1-docs into peril), I got
> /bin/sh: line 1: t: command not found
> make[2]: [html/haddock.css] Fehler 127 (ignoriert)
> /usr/bin/install -c -m 644 html/*
> /usr/local/share/ghc-6.2.2/html/libraries/base
> /usr/bin/install: Aufruf von stat für »html/*« nicht möglich: Datei oder
> Verzeichnis nicht gefunden
> make[2]: *** [install-docs] Fehler 1
> make[1]: *** [install-docs] Fehler 1
> make[1]: Leaving directory `/usr/local/lib/ghc-6.2.2/libraries'
> make: *** [install-docs] Fehler 1
> linux:/usr/local/lib/ghc-6.2.2 #
> Apparently had a problem with SRC_HADDOCK_OPTS += -t "Haskell Hierarchical
> Libraries..."
> How can I fix all that?
> Thanks,
> Daniel


"In My Egotistical Opinion, most people's C programs should be
indented six feet downward and covered with dirt."
	-- Blair P. Houghton

More information about the Haskell-Cafe mailing list