[Haskell-cafe] if-then-else as rebindable syntax (was Re: Why doesHaskell have the if-then-else syntax?)

Brian Hulley brianh at metamilk.com
Thu Jul 27 13:55:03 EDT 2006

Niklas Broberg wrote:
> Also, is cond the best name for the suggested function? If we don't
> expect anyone to really use it without the sugar, we could name it
> whatever weird thing so as to break as few existing programs as
> possible. It would make explicit import a bit more akward though. But
> I suspect that if this function did exist in the Prelude, people would
> start using it a lot. Does anyone have any better suggestions, or is
> cond the name of the day?

I suggest:
                if_then_else :: a -> b -> b -> b

as the name of the function so that "cond" could be used for the new 
construct suggested by Tomasz.

Regards, Brian.
Logic empowers us and Love gives us purpose.
Yet still phantoms restless for eras long past,
congealed in the present in unthought forms,
strive mightily unseen to destroy us.


More information about the Haskell-Cafe mailing list