[Haskell-cafe] Re: Haskore dependency trouble

Simon Marlow simonmar at microsoft.com
Thu Jul 13 06:39:03 EDT 2006

On 13 July 2006 11:27, Bulat Ziganshin wrote:

> Hello Simon,
> Thursday, July 13, 2006, 1:40:22 PM, you wrote:
>>>> I have some changes to Cabal partly finished that will address
>>>> this. Don't worry, it's coming.
>>> thanks, i will be glad to see it. but it will be GHC66-only?
>> No, just a new version of Cabal, which will work with 6.4.x.
> anyway it will require from user to upgrade his Cabal installation
> before installing my library. and what if he then comes to install
> some lib what is bundled for Cabal shipped with ghc 6.4.2 ? :(

Maybe the new Cabal will be backwards compatible, in which case there's
no problem.  If it isn't, then you can install two versions of Cabal
side by side (this is supported using the cabal-setup program), or (b)
the maintainer of the other package should update the package for the
new Cabal.


More information about the Haskell-Cafe mailing list