[Haskell-cafe] cabal specify a "tested version", ghci target?

Isaac Jones ijones at syntaxpolice.org
Sun Aug 20 18:05:17 EDT 2006

Duncan Coutts <duncan.coutts at worc.ox.ac.uk> writes:

> On Sat, 2006-08-12 at 03:52 +0200, Marc Weber wrote:
>> 1.)
>> 	I know I can use
>> 		Build-Depends:   lib == <version>, lib2 < version, lib3 >= version
>> 	and so on.
>> 	Do you think it would be useful to introducue some notation to indicate
>> 	a "tested with" ?
>> 	Reason, purpose: I think its sometimes the case that a author/ mantainer
>> 	is quite busy with other projects and misses that some dependencies
>> 	break things.. If you want to try out you're left with some compiler
>> 	errors and a dependency and have to try out which version works.
>> 	I would propose using this syntax:
>> 		lib-1.3 >=1.1 
>> 	to indicate that lib 1.1 is required at leeast and tested with up to
>> 	1.3.. Cabal might then give a warning if you try to use 1.4 or greater
>> 	"using newer version than tested" or similar..
>> 	What do you think?
>> 	Would this be useful?
> Well there is actually already a "tested-with:" field that you can put
> in a .cabal file, however at the moment it refers only to the Haskell
> implementation, eg ghc-x.y, hugs-x.y etc not to versions of libraries.
> Yes, I think it's a quite reasonable argument to extend this to include
> exact versions of libraries that it has been tested with.
> What do others think?

Sounds OK if someone wants to do it, but I don't think it should be a
high priority... I'd rather see support for stuff like this built into
HackageDB. I really want to have a "stable", "testing", and "unstable"
sections in Hackage where testing and stable have packages that are
known to work (or at least build) together.



More information about the Haskell-Cafe mailing list