[Haskell-cafe] Re: GHC cannot compile my code

Joel Reymont joelr1 at gmail.com
Wed Nov 9 11:22:38 EST 2005

Part of the problem seems to do with 218 newtypes that I have in one  
module that I'm importing  and about 30 newtype/data in another  
imported module.

I moved just 7 HList types into a separate module but still could not  
compile. I then tried just 4 and then just 2 and still no dice. This  
makes me think that the problem could be somewhere else. Could it  
have to do with HList enabling overlapped and undecided instances and  
ghc not being able to decide something?

On Nov 9, 2005, at 4:06 PM, Joel Reymont wrote:

> Folks,
> I'm on Mac OSX 10.4.3 with 1Gb of memory and GHC 6.4.1. I'm using  
> HList to define 92 structures in a module. I'm not using classes.
> There's some nesting going on (see below). Few datypes above are  
> data, mostly they are newtypes around Word32s, Strings, and lists  
> of those. I have 40 newtypes that wrap HLists and homogeneous lists  
> of HList types, 52 are type  aliases around HLists.
> Both with and without -O ghc cannot compile my module. I run out of  
> physical memory within 2-3 minutes and then it's just swapping (I  
> think) and the system becomes totally unresponsive.


More information about the Haskell-Cafe mailing list