[Haskell-cafe] Proper way to write this

Donn Cave donn at drizzle.com
Mon Dec 26 13:02:51 EST 2005


Quoth Pupeno <pupeno at pupeno.com>:
| On Monday 26 December 2005 02:41, Donn Cave wrote:
|> I don't think it will be too much worse. I would not try to
|> combine the struct updates, in the "both" case -- it doesn't buy
|> you anything, and pulls you into duplication you don't want.

| What about this
|
| runDaytimeServer :: DaytimeServer -> IO DaytimeServer
| runDaytimeServer dts = do
|   dts' <- runStreamDaytimeServer dts
|   dts' <- runDgramDaytimeServer dts'
|   return dts'
|
| ?
|
| I moved the structure update of dts into run_DaytimeServer.

Right, that's what I was thinking.

	Donn Cave, donn at drizzle.com


More information about the Haskell-Cafe mailing list