<div dir="ltr"><div class="gmail_default" style="font-family:times new roman,serif;font-size:large">Thanks, there seems to be dependency issues:<br><br>cabal install --allow-newer=base -j3 cabal-install<br>Resolving dependencies...<br>In order, the following would be installed:<br>deepseq-1.3.0.2 (latest: 1.4.0.0) (new version)<br>bytestring-0.10.4.1 (new version)<br>containers-0.5.6.2 (reinstall) changes: deepseq-1.4.0.0 -> 1.3.0.2<br>pretty-1.1.2.0 (new version)<br>text-1.2.0.3 (reinstall) changes: bytestring-0.10.6.0 -> 0.10.4.1,<br>deepseq-1.4.0.0 -> 1.3.0.2<br>parsec-3.1.7 (reinstall) changes: bytestring-0.10.6.0 -> 0.10.4.1<br>network-uri-2.6.0.1 (new package)<br>time-1.4.2 (latest: 1.5.0.1) (new version)<br>random-1.1 (reinstall) changes: time-1.5.0.1 -> 1.4.2<br>unix-2.7.1.0 (reinstall) changes: bytestring-0.10.6.0 -> 0.10.4.1,<br>time-1.5.0.1 -> 1.4.2<br>directory-1.2.1.0 (new version)<br>network-2.6.0.2 (new package)<br>HTTP-4000.2.19 (new package)<br>process-1.2.1.0 (reinstall) changes: deepseq-1.4.0.0 -> 1.3.0.2,<br>directory-1.2.1.1 -> 1.2.1.0<br>Cabal-1.20.0.3 (new version)<br>zlib-0.5.4.2 (new package)<br>cabal-install-1.20.0.6 (new package)<br>cabal: The following packages are likely to be broken by the reinstalls:<br>semigroups-0.16.0.1<br>void-0.7<br>contravariant-1.2.0.1<br>semigroupoids-4.2<br>bifunctors-4.2<br>comonad-4.2.2<br>parallel-3.2.0.6<br>hscolour-1.20.3<br>hpc-0.6.0.2<br>ghc-7.10.0.20141222<br>hoopl-3.10.0.2<br>hastache-0.6.1<br>haskeline-0.7.2.0<br>cereal-0.4.1.0<br>monad-par-extras-0.3.3<br>binary-0.7.2.3<br>bin-package-db-0.0.0.0<br>Cabal-1.22.0.0<br>attoparsec-0.12.1.2<br>abstract-deque-0.3<br>Glob-0.7.5<br>scientific-0.3.3.3<br>polyparse-1.11<br>cpphs-1.18.6<br>haskell-src-exts-1.16.0.1<br>hashable-1.2.3.1<br>unordered-containers-0.2.5.1<br>blaze-builder-0.3.3.4<br>MonadRandom-0.3.0.1<br>extra-1.0<br>cmdargs-0.10.12<br>directory-1.2.1.1<br>ansi-terminal-0.6.2.1<br>ansi-wl-pprint-0.6.7.1<br>Use --force-reinstalls if you want to install anyway.<br></div></div><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Jan 1, 2015 at 1:34 PM, Johan Tibell <span dir="ltr"><<a href="mailto:johan.tibell@gmail.com" target="_blank">johan.tibell@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Try<div><br></div><div>cabal install --allow-newer=base -j3 cabal-install<br></div><div><br></div><div>Once GHC 7.10 is out we might make another Cabal 1.20 release to bump the upper bound on the base dependency if 1.20 is indeed compatible with the latest base.</div></div><div class="gmail_extra"><br><div class="gmail_quote"><div><div class="h5">On Thu, Jan 1, 2015 at 12:08 PM, George Colpitts <span dir="ltr"><<a href="mailto:george.colpitts@gmail.com" target="_blank">george.colpitts@gmail.com</a>></span> wrote:<br></div></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div class="h5"><div dir="ltr"><div class="gmail_default" style="font-family:times new roman,serif;font-size:large"><br></div><div class="gmail_extra"><br><div class="gmail_default" style="font-family:times new roman,serif;font-size:large;display:inline">​$ ​</div>cabal update<br>Downloading the latest package list from <a href="http://hackage.haskell.org" target="_blank">hackage.haskell.org</a><br>Note: <b>there is a new version of cabal-install available.</b><br>To upgrade, run: cabal install cabal-install<br>bash-3.2$ <b>cabal install -j3 cabal-install </b><div class="gmail_default" style="font-family:times new roman,serif;font-size:large;display:inline"><b>​...​</b></div><b><br>Resolving dependencies...<br>cabal: Could not resolve dependencies:</b><br>trying: cabal-install-1.20.0.6 (user goal)<br>trying: base-4.8.0.0/installed-779... (dependency of cabal-install-1.20.0.6)<br>next goal: process (dependency of cabal-install-1.20.0.6)<br>rejecting: process-1.2.1.0/installed-2db... (conflict: unix==2.7.1.0, process<br>=> unix==<a href="http://2.7.1.0/installed-4ae.." target="_blank">2.7.1.0/installed-4ae..</a>.)<br>trying: process-1.2.1.0<br>next goal: directory (dependency of cabal-install-1.20.0.6)<br>rejecting: directory-1.2.1.1/installed-b08... (conflict: directory =><br>time==<a href="http://1.5.0.1/installed-c23.." target="_blank">1.5.0.1/installed-c23..</a>., cabal-install => time>=1.1 && <1.5)<br>rejecting: directory-1.2.1.0 (conflict: base==<a href="http://4.8.0.0/installed-779.." target="_blank">4.8.0.0/installed-779..</a>.,<br>directory => base>=4.5 && <4.8)<br>rejecting: directory-1.2.0.1, 1.2.0.0 (conflict:<br>base==<a href="http://4.8.0.0/installed-779.." target="_blank">4.8.0.0/installed-779..</a>., directory => base>=4.2 && <4.7)<br>rejecting: directory-1.1.0.2 (conflict: base==<a href="http://4.8.0.0/installed-779.." target="_blank">4.8.0.0/installed-779..</a>.,<br>directory => base>=4.2 && <4.6)<br>rejecting: directory-1.1.0.1 (conflict: base==<a href="http://4.8.0.0/installed-779.." target="_blank">4.8.0.0/installed-779..</a>.,<br>directory => base>=4.2 && <4.5)<br>rejecting: directory-1.1.0.0 (conflict: base==<a href="http://4.8.0.0/installed-779.." target="_blank">4.8.0.0/installed-779..</a>.,<br>directory => base>=4.2 && <4.4)<br>rejecting: directory-1.0.1.2, 1.0.1.1, 1.0.1.0, 1.0.0.3, 1.0.0.0 (conflict:<br>process => directory>=1.1 && <1.3)<br>Dependency tree exhaustively searched.<br></div></div>
<br></div></div>_______________________________________________<br>
ghc-devs mailing list<br>
<a href="mailto:ghc-devs@haskell.org" target="_blank">ghc-devs@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/ghc-devs" target="_blank">http://www.haskell.org/mailman/listinfo/ghc-devs</a><br>
<br></blockquote></div><br></div>
</blockquote></div><br></div>