"strange" error

asyropoulos at aol.com asyropoulos at aol.com
Thu Mar 15 18:39:38 UTC 2018


I have compiled the latest veersion of ghc under OpenIndiana (Solaris) and now I am
trying to compile cabal. I downloaded the source code from


and I tried to compile. I used the bootstrap.sh script bit it failed:

Configuring cabal-install-
Setup: Encountered missing dependencies:
HTTP >=4000.1.5 && <4000.4,
async >=2.0 && <3,
cryptohash-sha256 ==0.11.*,
hackage-security >= && <0.6,
hashable >=1.0 && <2,
tar >= && <0.6

Error during cabal-install bootstrap:
Configuring the cabal-install package failed.

The script downloaded all these packages so I tried to see why they fail:

$ cd HTTP-4000.3.7
$ ls
CHANGES     HTTP.cabal  Network     test
dist        LICENSE     Setup.lhs
$ runhaskell Setup configure
Configuring HTTP-4000.3.7...
Setup: Encountered missing dependencies:
base >= && <4.11

Of course this package is already installed and this means that
for some reason it cannot find it. It is quite possible that I am doing
something stupid but I would like to know how can I proceed?

Thanks in advance for your help/assistance.

Apostolos Syropoulos
Xanthi, Greece

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/glasgow-haskell-users/attachments/20180315/e2826aee/attachment.html>

More information about the Glasgow-haskell-users mailing list