cannot build 'vector' with profiling

Ranjit Jhala jhala at
Wed Jun 10 04:18:30 UTC 2015

Hi all,

I cannot build 'vector' (or 'cmdargs') with profiling on.

specifically when I run:

    $ cabal install --enable-executable-profiling
--enable-library-profiling --ghc-options="-O2 -rtsopts -prof -auto-all
-caf-all" vector

I get the message:

    Perhaps you haven't installed the "p_dyn" libraries for package

Per some advice I tried to add the '--disable-shared'

    $ cabal install --disable-shared --enable-executable-profiling
--enable-library-profiling --ghc-options="-O2 -rtsopts -prof -auto-all
-caf-all" vector

but then I get this:

    Loading package primitive-0.6 ... <command line>: can't load .so/.DLL
for: libHSprimitive-0.6.dylib (dlopen(libHSprimitive-0.6.dylib, 9): image
not found)

Any idea whats going on or for any work arounds? Pretty stumped! Thanks in

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Glasgow-haskell-users mailing list