hmatrix- installation problem

Adrian Victor Crisciu acrisciu at
Fri Aug 22 09:55:00 UTC 2014

I tried the following command line:

cabal install --enable-documentation
--extra-include-dirs=/usr;local/include --extra-lib-dirs=/usr/local/lib

and got the following:

Resolving dependencies...
Configuring hmatrix-
cabal: Missing dependencies on foreign libraries:
* Missing C libraries: blas, lapack
This problem can usually be solved by installing the system packages that
provide these libraries (you may need the "-dev" versions). If the libraries
are already installed but in a non-standard location then you can use the
flags --extra-include-dirs= and --extra-lib-dirs= to specify where they are.
Failed to install hmatrix-
cabal: Error: some packages failed to install:
hmatrix- failed during the configure step. The exception was:
ExitFailure 1

As I said before, the libraries for blas and lapack ARE in /usr/local/lib
and the header files ARE in /usr/local/include.

Is it possible for hmatrix to look for another version of atlas/blas and
lapack? I have installed atlas-3.3.8 and lapack-3.4.0

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Glasgow-haskell-users mailing list