Error building ghc on raspberry pi.

Thijs Alkemade me at
Tue Jan 15 17:41:45 CET 2013

Op 15 jan. 2013, om 17:36 heeft roconnor at het volgende geschreven:

> Okay, I tried:
> SRC_HC_OPTS        = -H64m -Rghc-timing -optc-mfloat-abi=hard -optc-march=armv6 -optc-mfpu=vfp -optlc=-mattr=+vfp2
> GhcStage1HcOpts    = -O -fllvm
> GhcStage2HcOpts    = -O0 -fllvm
> GhcLibHcOpts       = -O -fllvm -optlc-float-abi=hard
> and I got the same error at a different build step.  I'm not sure if it is earlier or later.
> It seems still not everything is using the hard-float ABI.
> ===--- building final phase
> make -r --no-print-directory -f phase=final all
>  HC [stage 1] utils/hsc2hs/dist-install/build/tmp/hsc2hs
> /usr/bin/ld: error: utils/hsc2hs/dist-install/build/tmp/hsc2hs uses VFP register arguments, utils/hsc2hs/dist-install/build/Main.o does not
> /usr/bin/ld: failed to merge target specific data of file utils/hsc2hs/dist-install/build/Main.o

Did you do a `make clean` first? If not, try removing just (some of) the offending .o files, and see if rebuilding just those results in the same error.


More information about the Glasgow-haskell-users mailing list