GHC 7.8 release?

Johan Tibell johan.tibell at
Fri Feb 8 04:55:44 CET 2013

On Thu, Feb 7, 2013 at 6:48 PM, Ben Lippmeier <benl at> wrote:

> Right now, the latest packages uploaded to Hackage get built with ghc-7.6
> (only), and all the pages say "Built on ghc-7.6". By doing this we force
> *all* library developers to run GHC 7.6. I think this sends the clearest
> message about what the "real" GHC version is.

I don't know how closely users look at the "built on" line on the package
page. Perhaps they look there, perhaps they don't.

Between Bryan and me we build all of our own packages and all HP packages
on the latest 3 GHC versions:

That doesn't mean that it would be a bad idea to build all Hackage packages
on using more GHC versions, but that won't happen until the Hackage project
is unstuck (it has been stuck for years!).

-- Johan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Glasgow-haskell-users mailing list