32-bit libs required for 64-bit install

Yitzchak Gale gale at sefer.org
Sun Aug 25 14:48:01 CEST 2013

I had trouble installing the generic 64-bit Linux tarball for 7.6.3.
With some help from Ian, who pointed out that the problem was
related to ld-linux.so, I finally figured out the root of the problem:
the installation requires *both* the 64-bit and 32-bit
versions of libc6 plus deps to be available.

Once the installation was complete, I could then remove the
32-bit libs and ghc still seems to work. It appears that the
32-bit libs are only required for some of the auxiliary executables
that come with the tarball, such as ghc-pwd.

Is there any reason in principle that we only allow 64-bit GHC
to be installed on multiarch Linux? That seems like a rather
arbitrary restriction.

In the meantime, something ought to be said about this on the
download page.

More details: the target system for the installation in my case
was an up-to-date Ubuntu 12.04 LTS (precise) amd64 headless
server running in a VMware containter.


More information about the Glasgow-haskell-users mailing list