Error while installing new packages with GHC 7.4.1

Albert Y. C. Lai trebla at
Thu Mar 1 02:02:11 CET 2012

On 12-02-29 06:04 AM, Antoras wrote:
> I don't know where the dependency to array- comes from. Is it
> possible to get more info from cabal than -v?

hoogle-4.2.8 has "Cabal >= 1.8 && < 1.13", this brings in Cabal-1.12.0.

Cabal-1.12.0 has "array >= 0.1 && < 0.4", this brings in array-

It is a mess to have 2nd instances of libraries that already come with 
GHC, unless you are an expert in knowing and avoiding the treacherous 
consequences. See my

It is possible to fish the output of "cabal install --dry-run -v3 
hoogle" for why array- is brought in. It really is fishing, since 
the output is copious and of low information density. Chinese idiom: 
needle in ocean (haystack is too easy). Example:

"selecting hoogle-4.2.8 (hackage) and discarding Cabal-1.1.6, 1.2.1,,,,,,,,,,
1.14.0, blaze-builder-0.1, case-insensitive-0.1,"

We see that selecting hoogle-4.2.8 causes ruling out Cabal 1.14.0

Similarly, the line for "selecting Cabal-1.12.0" mentions ruling out 

More information about the Glasgow-haskell-users mailing list