ANNOUNCE: GHC 7.4.1 Release Candidate 2

Evan Laforge qdunkan at
Wed Feb 1 08:05:25 CET 2012

So it embarrasses me to admit it, but I'm having the same problem I
always have when I install a new ghc, and that's cabal and cabal

I downloaded the latest cabal-install from and that was a
mistake right off.  After fiddling around I figured out I apparently
need the one bundled with ghc... and sure enough, the source version
has a cabal-install-0.13.3.  This one has newer but also has out of
date dependencies:

Configuring cabal-install-0.13.3...
Setup.hs: At least the following dependencies are missing:
Cabal >=1.13.3 && <1.14,
base >=2.0 && <2.2,
filepath >=1.0 && <1.3,
time >=1.1 && <1.3,

But shouldn't cabal-install be updated for the version of ghc it's
with?  I cloned branch 7.4 and did a ./sync-all pull so I should have
the latest version, right?  And how are other people testing this out
if cabal-install has out of date dependencies?  And strangest, why is
the 'base' dependency so old?

And while I'm wondering about cabal, why on earth is it that so many
Setup.hs files are actually Setup.lhs and with no actual literate

Oh, and before I could have any of those problems, the binary
distribution itself didn't want to install: it was evidently compiled
against libgmp3 and archlinux is now installing libgmp5 with no option
to downgrade (though oddly it calls it .10 in the so file).  I tracked
down an old libgmp and install with tar since arch doesn't seem to
want more than one libgmp installed simultaneously.

I don't know how many other linuxes out there do this, but I know I'm
not the only archlinux using haskell user.

More information about the Glasgow-haskell-users mailing list