Linker error

Luca Ciciriello luca_ciciriello at
Tue Mar 15 09:55:02 CET 2011

My problem is that I can't downgrade Xcode and trying to reinstall the Haskell Platform 2010.2.0.0, I've found out that many packages are missing (i.e. IO doesn't exist any more). So in this moment I haven't a working Haskell Platform. Too bad.

Another strange thing is that I have in my /usr/lib the library crt1.10.5.o. So why is ghc unable to find it? Xcode 4 has just add in /usr/lib the new library crt1.10.6.o, without removing the old one.

I hope that a new fixed Haskell platform will be released as soon as possible.


On Mar 14, 2011, at 4:55 PM, Don Stewart wrote:

> There's an open bug ticket about XCode 4 not linking properly (I think
> due to the new dtrace support making GHC builds tied to a specific
> XCode version).
> Can you downgrade to XCode 3 in the meantime?
> On Mon, Mar 14, 2011 at 8:43 AM, Luca Ciciriello
> <luca_ciciriello at> wrote:
>> Hi All.
>> I've just installed the new Haskell platform (2011.2.0.0) on my MacOS X 10.6.6 with Xcode 4
>> Now the problem is that when I try to build my Haskel programs I receive the linker error:
>> Linking lexer ...
>> ld: library not found for -lcrt1.10.5.o
>> collect2: ld returned 1 exit status
>> Any idea?
>> Thanks in advance.
>> Luca
>> _______________________________________________
>> Glasgow-haskell-users mailing list
>> Glasgow-haskell-users at

More information about the Glasgow-haskell-users mailing list