GHC build error: cannot satisfy -package ghc-7.1.20110217

Dave Bayer bayer at
Thu Mar 10 04:36:55 CET 2011

On Mar 9, 2011, at 9:44 PM, Dave Bayer wrote:

> I still can't use cabal-install on one copy of 7.0.2 to install to another copy of 7.0.2, but it looks like something I'll manage to sort out without help.

cabal install cabal-install tries to install 0.8.2, and fails.

cabal install cabal-install-0.10.2 works.

Yes I ran cabal-update first. I have no idea where it gets the idea it should install 0.8.2 when newer versions are evident, particularly when this doesn't even work.

More information about the Glasgow-haskell-users mailing list