Chris Dornan chris at
Sat Jul 30 00:19:43 CEST 2011

Thanks Ian,

It's much appreciated. As I said to Daniel, I have just tried building 7.2.1
RC1 with the same failure. 

Yes, by "quick-test" I mean the build flavour. (Basically I am explaining
exactly how I am configuring the default build, which does work for me.)

My point was that I had worked my way through pretty every post-6.12.1
official release, switching between CentOS 5 & CentOS 6, building with a
variety of binary releases, with the same result -- and it's still happening
with 7.2.1 RC1!

Clearly I am doing something very, very silly -- but what?

I can see two obvious ways forward:

	* try installing another of the Linux distros and seeing if I can
repeat the problem there or

	* spend some time digging into one of the broken builds to try and
find out what is happening.

I think the second option may be more productive.
If anybody has any bright ideas I will be happy to try them out.



-----Original Message-----
From: Ian Lynagh [mailto:igloo at] 
Sent: 29 July 2011 21:42
To: Chris Dornan
Cc: glasgow-haskell-users at
Subject: Re: integer-simple

On Fri, Jul 29, 2011 at 05:51:23PM +0100, Chris Dornan wrote:
> But when I repeat with  INTEGER_LIBRARY = integer-simple (on quick 
> test)
> GHCi, version 6.12.3:  :? for help

Note that 6.12.3 is quite old now, and neither that branch or the 7.0 branch
are still being developed.

By "quick test" do you mean the "quickest" build flavour from

I've just validated HEAD with INTEGER_LIBRARY=integer-simple and the build
went through fine, and ghci works.


More information about the Glasgow-haskell-users mailing list