haskell-platform configures failed on Ubuntu 11.04

Albert Y. C. Lai trebla at vex.net
Sat Jul 23 04:37:53 CEST 2011

On 11-07-22 02:26 PM, David Smith wrote:
> I tried to build the newest haskell-platform-2011.2.01 from source on
> Ubuntu 11.04, following the instructions
> http://www.vex.net/~trebla/haskell/haskell-platform.xhtml. But there was
> still an configure error.
> checking for library containing glEnd... no
> configure: error: The OpenGL C library is required
> The following are the libraries I already installed
> sudo apt-get install libgl1-mesa-dev
> sudo apt-get install libglc-dev
> sudo apt-get install freeglut3-dev
> sudo apt-get install libedit-dev
> sudo apt-get install libglw1-mesa libglw1-mesa-dev

I just tested again in a fairly clean Ubuntu 11.04 (Desktop) 
installation plus the concerned *-dev packages (first just those in my 
instructions, then plus your extra ones) plus ghc 7.0.3. I cannot 
reproduce the error. The configure script figured out

checking for library containing glEnd... -lGL

just fine. There was no error.

More information about the Glasgow-haskell-users mailing list