backward compatibility

Ian Lynagh igloo at
Fri Jan 21 03:00:16 CET 2011

On Thu, Jan 20, 2011 at 05:09:58PM -0000, Sittampalam, Ganesh wrote:
> >From the point of view of darcs, which is usually trying to support 2 or 3 GHC versions at a time, one cycle of deprecation makes life a lot simpler. We do look at warnings and try to fix them, but it's nicer not to have to do so in a real hurry.

Note that in 2 of these cases (FlexibleInstances and BangPatterns), once
the package is fixed for 7.2 it will still work with older versions.
And actually, Cabal ought to accept NondecreasingIndentation (and do
nothing) for older GHCs too; I've just written a patch to fix that.

So these aren't changes where you need anything like ifdefs to support
both before and after.


More information about the Glasgow-haskell-users mailing list