Cabal constraint solver

Daniel Fischer at
Sat Oct 2 20:38:57 EDT 2010

On Sunday 03 October 2010 02:10:11, Felipe Lessa wrote:
> On Sat, Oct 2, 2010 at 8:29 PM, Daniel Fischer < at> 
> > Yes, cabal looks at the package-index to find out the required
> > dependencies, it doesn't know where you have local source files.
> Actually, this is cabal-install.  If you 'cabal unpack' then
> 'runhaskell Setup.hs configure' and 'runhaskell Setup.hs build', maybe
> it works =).

Worked for me with cabal (as in, the executable provided by cabal-install).

$ cabal unpack package-with-bad-constraints
$ cd package-with-bad-constraints
-- change constraints in package-with-bad-constraints.cabal
$ cabal install
$ cabal install package-which-depends-on-previous

If I changed the version, it worked (unless I overlooked a package with bad 
constraints), if not, it tried to reinstall (and failed of course).

> But the suggestion about increasing the version number is good anyways.
> Cheers! =)

More information about the Glasgow-haskell-users mailing list