hsc2hs on Mac OS 10.6 unreliable?

Chris Kuklewicz haskell at list.mightyreason.com
Wed Jun 9 09:04:55 EDT 2010

That was in the official hsc2hc binary but was commented out in my
macports hsc2hs.  I have uncommented the line and rebuilt a working gtk2hs.


On 09/06/2010 09:30, Christian Maeder wrote:
> Chris Kuklewicz schrieb:
>> hsc2hs: On OS 10.6 ghc is calling hsc2hs without any special -arch
>> option, and hsc2hs is calculating offsets in x86_64 mode.  This is
>> breaking the interface between ghc and c-structures for various
>> libraries.  In particular I ran into this with gtk2hs.
>> It may suffice to get '--cc-flag=-m32 --ld-flag=-m32' to hsc2hs as a
>> work around.  While ticket #2965 is not yet fixed it would be better if
>> hsc2hs understood the default arch on OS X 10.6 is not compatible with ghc.
> Sorry, I'm only on a 32bit Mac, but my (installed) hsc2hs (for
> ghc- file contains:
> HSC2HS_EXTRA="--cflag=-m32 --lflag=-m32 -I<...>
> Is this not sufficient for 64bit Macs, too?
> Cheers Christian

More information about the Glasgow-haskell-users mailing list