How to solve ghc-stage2: mkTextEncoding: invalid argument (Invalid argument) issue.

Simon Marlow marlowsd at
Thu Sep 17 04:17:35 EDT 2009

On 16/09/2009 15:06, Karel Gardas wrote:
> Thanks to Christian note I solved the issue. Also thanks to Matthias'
> advice I've been able to configure ghc to use GNU iconv in /usr/local,
> but the result was still the same. I later used Christian advice to
> force ghc not to use /usr/local's iconv and this really configured
> correctly (like sparky's: checking for library containing iconv... none
> required) and now finally my buildbot is working even for head.
> Note the provided /usr/local iconv is probably from package provided by
> and is there from the old SXDE 1/08 installation. Now
> I'm using OpenSolaris 2009.06 and trying to get rid of such additions
> which are no longer needed.
> Thanks for all the help provided!

Glad you got it going.  I notice there are a few test failures, many of 
which could be fixed easily, e.g.

--- ./lib/IO/hClose002.stdout.normalised        Wed Sep 16 14:08:09 2009
+++ ./lib/IO/    Wed Sep 16 14:08:09 2009
@@ -1,4 +1,4 @@
-Left hClose002.tmp: hClose: invalid argument (Bad file descriptor)
+Left hClose002.tmp: hClose: invalid argument (Bad file number)
  Right ()
  Right ()
  Right ()
*** unexpected failure for hClose002(normal)

that just needs a platform-specific expected output file 


More information about the Glasgow-haskell-users mailing list