array- doesn't build with 6.12rc1

Sittampalam, Ganesh ganesh.sittampalam at
Mon Nov 2 13:11:24 EST 2009

Ian Lynagh wrote:

> You already have the array package if you installed the RC.
>     The problem is that the darcs.cabal file says: build-depends:
>                    [...] array      >= 0.1 && < 0.3,
>                    [...]
> so it's not using it.

Oh, I see. Sorry for the noise - I got confused about what has been
removed from the GHC distro and what hasn't.

(Looks like there's at least one dependency with the same problem, so it
could all get rather fiddly. Natural consequence of the safety-first
approach of the PVP, I guess.)


 Please access the attached hyperlink for an important electronic communications disclaimer: 

More information about the Glasgow-haskell-users mailing list