Can't find parsec

Colin Paul Adams colin at
Sat Mar 21 13:02:07 EDT 2009

>>>>> "Don" == Don Stewart <dons at> writes:

    Don> colin:
    >> I am trying to incorporate Dana Xu's static contract checking
    >> code into ghc 6.11. I've run into a problem that puzzles me. I
    >> am getting the following error message:
    >> verify/SimplIface.lhs:16:7: Could not find module
    >> `Text.ParserCombinators.Parsec.Language': Use -v to see a list
    >> of the files searched for.
    >> But a quick find command shows that
    >> ./utils/ext-core/Language/Core/ParsecParser.hs
    >> has this very same import, so I figure it must be usable within
    >> the compiler.  What do I have to do to get it to find this
    >> module?

    Don>     cabal install parsec?

Well, I thought it was installed (I already have pasec-3.0.0 installed
by cabal for the game I'm writing.).

But I see now that if I try it I get parsec 2 installed.

However, I still get the same error message.
Colin Adams
Preston Lancashire

More information about the Glasgow-haskell-users mailing list