Under Solaris: GHC 6.10.2 Release Candidate 1

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Tue Mar 17 20:28:50 EDT 2009

On Tue, 2009-03-17 at 11:09 +0100, Christian Maeder wrote:
> GHC 6.10.2 will have a problem with cabal-install-0.6.2!
> When I tried to install cabal-install-0.6.2 for ghc-
> I needed to change #!/bin/sh to #!/bin/bash in bootstrap.sh to avoid the
> following errors:
> -bash-3.00$ ./bootstrap.sh
> Checking installed packages for ghc-
> ./bootstrap.sh: !: not found

> Under Solaris sh is not bash!


According to the OpenGroup that syntax should be fine:

It works for me under Solaris 10. Perhaps Solaris 9 or older do not have
a standard compliant /bin/sh program. What do you suggest we use instead
as a workaround?

> Next, ghc- comes with package unix-, but
> cabal-install.cabal requests:
>   unix >= 2.0 && < 2.4
> Changing to "<= 2.4" was not sufficient, so I changed it to "<= 2.5".
> This will affect any OS!

Hmm, it's a bit suspicious that the major version number is changing in
a minor ghc release. Do we know what the API breakage is? This could
affect any program.


More information about the Glasgow-haskell-users mailing list