Attempted install on Mac OS X - recent versions - FAIL

Phil Dennis pjdennis at
Wed Jul 29 01:29:47 EDT 2009

I am looking for some assistance with installing GHC on Mac OS X. If
there is a more appropriate place for me to ask, please let me know.

I have tried, with no luck so far, the 2 different binary
distributions of 6.10.4 provided for the Mac on the ghc
download page (

I have OS X version 10.5.7 with XCode version 3.1.2 installed.

When I run the installer (GHC-6.10.4-i386.pkg) I get as far as the
"Installation Type" screen with the following text displayed: "Click
Install to perform a standard installation of this software for all
users of this computer". However the 'Install' button is greyed out
and cannot be clicked. The last entries in the installer log are as
Jul 29 00:03:29 phil-denniss-macbook-pro Installer[11740]: Glasgow
Haskell Compiler Installation Log
Jul 29 00:03:29 phil-denniss-macbook-pro Installer[11740]: Opened
from: /Users/pjdennis/Downloads/GHC-6.10.4-i386.pkg
Jul 29 00:03:30 phil-denniss-macbook-pro installdb[11743]: started (uid 96)
Jul 29 00:03:30 phil-denniss-macbook-pro installdb[11743]: Opened
receipt database on '/' with schema 17.
Jul 29 00:03:36 phil-denniss-macbook-pro installdb[11743]: done.
(0.003u + 0.003s)


I tried the binary distribution (ghc-6.10.4-i386-apple-darwin.tar.bz2)
which I extracted, and then ran ./configure, as instructed in the
INSTALL file. After adding /Developer/usr/bin to the path (so that the
configure script could find the 'ar' program) I now get the following
error from the configure script:
configure: error: C compiler cannot create executables
See `config.log' for more details.

I have pasted some of what looks relevant from config.log, below.

Any help with either one of the install methods for OS X would be much
appreciated. I am keen to get started trying out Haskell, instead of
mucking with installers.


Phil Dennis

>From config.log

configure:2298: found /Developer/usr/bin/gcc
configure:2309: result: gcc
configure:2547: checking for C compiler version
configure:2554: gcc --version >&5
i686-apple-darwin9-gcc-4.0.1 (GCC) 4.0.1 (Apple Inc. build 5490)
Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

configure:2557: $? = 0
configure:2564: gcc -v >&5
Using built-in specs.
Target: i686-apple-darwin9
Configured with: /var/tmp/gcc/gcc-5490~1/src/configure
--disable-checking -enable-werror --prefix=/usr --mandir=/share/man
+/4.0.0 --with-slibdir=/usr/lib --build=i686-apple-darwin9
--with-arch=apple --with-tune=generic --host=i686-apple-darwin9
Thread model: posix
gcc version 4.0.1 (Apple Inc. build 5490)
configure:2567: $? = 0
configure:2574: gcc -V >&5
gcc-4.0: argument to `-V' is missing
configure:2577: $? = 1
configure:2600: checking for C compiler default output file name
configure:2627: gcc    conftest.c  >&5
ld: library not found for -lcrt1.10.5.o
collect2: ld returned 1 exit status
configure:2630: $? = 1
configure:2668: result:
configure: failed program was:
| /* confdefs.h.  */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| /* end confdefs.h.  */
| int
| main ()
| {
|   ;
|   return 0;
| }
configure:2675: error: C compiler cannot create executables
See `config.log' for more details.

More information about the Glasgow-haskell-users mailing list