can we bootstrap GHC 6.x?

Ian Lynagh igloo at
Sun Jul 26 10:14:54 EDT 2009

On Fri, Jul 24, 2009 at 10:43:46PM +0800, Shu Wu wrote:
> Hi buddies. I've been looking for methods to bootstrap GHC 6.10 but with no
> luck. It seems GHC 5.0 is the last version that provides HC source for
> bootstrapping. I think, however, bootstrapping GHC above 6.x is still
> necessary.
>   First, it will be easier to build GHC on a new platform, eg, OpenSolaris.

We have a procedure for porting to a new platform:

It's not perfectly smooth, and it's a bit of hassle, but you only need
to do it once for each platform.

>   Second, compiling GHC from strap is the only way to go into OpenSolaris'
> official package repository, since all packages for OpenSolaris are built by
> Source Juicer ( from pure source code, and
> there can't be any pre-installed GHC on Source Juicer Build Grid.

We recommend that distributions bootstrap GHC from a binary, in the same
way that they bootstrap gcc.


More information about the Glasgow-haskell-users mailing list