ANNOUNCE: GHC version 6.10.4

Yitzchak Gale gale at
Thu Jul 16 12:29:58 EDT 2009

>    The (Interactive) Glasgow Haskell Compiler -- version 6.10.4
> How to get it

I have a few comments about the "Distribution Packages" page
that is linked from there:


Remove the line "Newer packages may be available in Haskell Unsafe."
That stuff is very, very old.

Mac OS X:

Paragraph beginning "Contrary to the recommendation at
the top of this page... rather than using the alternatives
below." It makes no sense. It appears to be referring to
an older version of the page.

"Both 10.3 (Panther) and 10.4 (Tiger) are supported."
should be changed to 10.4 (Tiger) and 10.5 (Leopard).

The paragraph about the ghc-devel port should be removed,
I think. The port still exists, but it doesn't seem to be actively
supported since 6.7. Anyone who wants to use GHC HEAD
will probably just build current HEAD manually. (Greg - is
this correct?)


More information about the Glasgow-haskell-users mailing list