Preferred gcc for use with ghc

Christian Maeder Christian.Maeder at
Sat Jan 3 08:51:27 EST 2009

gcc version 4.0.1 (Apple Inc. build 5488) worked for me. I think it
comes from XCode 3.1 together with @(#)PROGRAM:ld  PROJECT:ld64-85.2.1

XCode 3.0 with gcc version 4.0.1 (Apple Inc. build 5465) and
@(#)PROGRAM:ld  PROJECT:ld64-77 works only on intel macs but not on
powerpc macs.

HTH Christian

Gregory Wright wrote:
> Hi,
> What is the preferred gcc to use with ghc 6.10.1?  I'm starting
> the long and doubtless slow process of putting together a more user
> friendly (and binary distributable) ghc distribution to be built using
> MacPorts.
> The guidance about gcc on the wiki is vague.  Is there a best choice?
> Or at least some versions to be avoided?
> Best,
> Greg

More information about the Glasgow-haskell-users mailing list